SD WS - SetTicketState - Vyřešeno/Uzavřeno/Znovu otevřeno - kontroluje se oprávnění, i když by v rámci vlastních programových rozšíření neměla
Článek se týká verzí produktů
ALVAO Service Desk 10.3 a vyšší
Příznaky
Pokud je metoda spouštěna v rámci vlastních programových rozšíření, může se po vykonání daného kódu zobrazit chyba 500 - "You have no permission ..."
Příčina
Příčinou je chyba v produktech ALVAO.
Řešení
Opraveno ve verzi 10.4.1059 - 10.4
Náhradní řešení
Pro změnu stavu na Vyřešeno používejte metodu WS - ResolveTicket.
Případně změnu stavu proveďte přes ALVAO.API - metodou Ticket.ChangeState
ChangeTicketStateSettingsModel.IgnoreRights nastavte na true
Kroky pro reprodukci tohoto chování
Přílohy
Číslo problému
T107064ALVAO
Nenašli jste co jste hledali? Zeptejte se našeho týmu technické podpory.
|